Back to the top

USB ports not staying enabled – Possible cause (Windows)

USB ports not staying enabled – Possible cause (Windows)

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #5350
    Anonymous

    Two possible solutions if you have to unplug and plug in your USB posts leading to external equipment.

     

    #1 – Usb Root Hub

    By default the USB Root Hub power management settings are set to turn off USB devices to save power. Here’s how to fix it.

    1. Navigate to ‘Device manager’, and open the ‘Universal Serial Bus controllers’ dropdown group at the bottom of the list.
    2. Scroll down to the first ‘USB Root Hub’, right click and select ‘Properties’.
    3. In the ‘USB Root Hub Properties’ window, click on the ‘Power Management’ tab at the far right.
    4. On the ‘Power Management’ tab, make sure that the checkbox ‘Allow the computer to turn off this device to save power’ in unchecked.
    5. Repeat these steps with remaining ‘USB Root Hubs’.

     

    #2 – USB Selective Suspend setting

    In the ‘Advanced Settings’ of power options there is also another setting that is by default set to disable the USB port to save power.

    1. Navigate to Control Panel and select ‘Power Options’.
    2. It should be by default selected on the ‘Balanced (recommended)’ plan. Click the ‘Change Plan Settings’ link at the right hand side.
    3. This will bring up the ‘Change Plan Settings’ page. Click the ‘Change advanced power settings’.
    4. This will bring up the ‘Advanced settings’ for the ‘Power Options’. Scroll down to ‘USB Settings’, and expand the menu until you see underneath it ‘USB selective suspend setting’. Make sure this is set to ‘Disabled’.
    5. Click ‘OK’ and close the windows.

    Hopefully this helps someone out there

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.
Copyright 2017-2021 Globelocus
X